Back to overview
Maintenance

Network Maintenance & Upgrades

May 06 at 01:00pm AEST  –  May 06 at 05:00pm AEST
Affected services
Radio Backend

Resolved
May 07 at 01:00pm AEST

We’re performing essential network upgrades. During this time, the backend for the Radio Discord Activity will be temporarily unavailable. Thanks for your patience!

Created
May 06 at 01:00pm AEST

Maintenance has been delayed, we will update you soon.